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LAB MANUAL  
MULTIMEDIA TECHNOLOGY LAB  

SYLLABUS  
1. Write a program to justify a text entered by the user on both the left and right 

hand side. For example, the test “An architect may have a graphics program to 

draw an entire building but be interested in only ground floor, can be justified in  
 
30 columns as shown below. An architect may have a Graphics programs draw 
an enteric building but be interested in only ground floor.  

 

2. Study the notes of a piano and stimulate them using the key board and 
store them in a file.  
 

3. Write a program to of java script.  

 

4. Devise a routine to produce the animation effect of a square transforming to 
a triangle and then to a circle.  
 

5. Write a program to show a bitmap image on your computer screen.  

 

6. Create a web page for a clothing company which contains all the details of 
that company and at-least five links to other web pages.  

 

7. Write a program by which we can split mpeg video into smaller pieces for the 

purpose of sending it over the web or by small capacity floppy diskettes and 

then joining them at the destination.  
 
8. Write a program to simulate the game of pool table.  
 

9. Write a program to simulate the game Mine Sweeper.  
 

10. Write a program to play “wave” or “midi” format sound files.  
 

11. Write a program to insert drop down list.  
 

12. Write a program to insert table.  
 
13 Write a program for Formatting Text. 
 
14. Write a program to multiple Images.  
 

15. How to work in Dreamweaver.  



 
 
Vision of Multimedia Lab: 

  
1) There are so many software tools of multimedia like Photoshop, flash, 

Dreamweaver so we organize this lab because students can practically 

understanding of tools. 

 

2) Students can create websites what they want from any multimedia software 

tools. 

 

3) Students can make games by using multimedia concepts. 

 

4) Multimedia is supportive for informal learning of science and technology. 

Multimedia provide new platform document. 
 
 
 

SOFTWARE AND HARDWARE REQUIRMENTS 

HARDWARE REQUIRMENTS FOR SERVER: 

 
PROCESSOR: P-IV 
 
RAM: 256MB 

 

HDD: 40GB 

 

SPEED: 2.4GHZ 

 

SOFTWARE REQUIRMENTS: 

 

OPERATING SYSTEM: WINDOWS 2003, 2007,WINDOWS 
XP 

 

Software tools: FLASH, PHOTOSHOP, DREAMWEAVER, C++ 



 
 

 

Experiment: 1  
AIM: -To study MULTIMEDIA HARDWARE system. 
a) INPUT DEVICES   
b) OUTPUT DEVICES   
c) COMMUNICATION DEVICES  
 
REQUIREMENTS: - Floppy Disc, Hard Disc, DVD, CD Rom, Input 
devices like Track Ball, Touch Screen, Mice, Flat Bed, Digital Camera, 
Output devices like Amplifier speaker, monitor, projector, Printer. 

 
THEORY: - 
INPUT DEVICES:  
A great variety or input devices -from the familiar keyboard and handy mouse to touch 
screen and voice recognition setups can be used for development and delivery or a 
multimedia project. 

 

1) KEYBOARD:  
A keyboard is the most common method of interaction with a Computer. Keyboards 
provide various tactile responses and have variously layout depending upon your 
Computer system and keyboard -model. Keyboard is typically rated at least 50 million 
cycles. The most common keyboard for PCs is the 1011 style, although many styles are 
available with one or more special keys LED’s. 

 
2) MICE: A mouse is the standard tool for interacting with a graphical user interface 
(QUI). All Macintosh computers require a mouse; on PCs, mouse: are not required but 
recommended. The buttons on the mouse provide additional user input, such as 
pointing and double clicking to open a document.  

 

3) TRACK BALL:   
Track ball are similar to mice except that the cursor is moved by using one or more 
fingers to roll across the top of the ball. The track ball does not need the flat space 
required by a mouse. Track ball have at least two buttons; one for the user to click, and 
the other to provide the press and hold condition necessary for selecting & dragging 
operation. 

 

4) TOUCHSCREEN:  
Touch screens are monitors that usually have a textured coating across the glass face. 
This coating is sensitive to pressure and register the location of the user’s finger when 
it touches the screen. The touch mate system, which has no coating, actually measures 
the pitch roll, and yaw rotation of the monitor when pressed by finger, and determine 
how much force exerted and the location where the force was applied. 



 
 
5) MAGNETIC CARD ENCODERS AND READERS: 

 

Magnetic card setups are useful when you need an interface for a data base application 

or multimedia project that tracks users. You need both card encoder and a card reader 

for this type of interface. The encoder connects to the computer at the serial port and 

transfer information to magnetic strip of tape on the back of the card. 
 

 

6) FLAT-BED SCANNERS:  
A scanner may be the most useful piece of equipment you will use in the course of 
producing a multimedia project. There are flat bed scanner and handheld scanners. 
Most commonly available are gray -scale and color flat- bed scanners that provide a 
resolution of 300 or 600 dots per inch. Professional graphics houses may use even 
higher resolution unit. 

 

7) OPTICAL CHARACTER RECOGNITION (OCR) DEVICES: OCR 

 

Software such as Omni page from acre or perceive from corona, to convert printed 

matter to ASCII text files in our computer. We can also convert paper document into a 

word processing document on our computer without retyping or rekeying. An OCR 

terminal can be of use to multimedia developer because it recognizes not only printed 

characters but also handwriting. 
 
8) INFRARED REMOTES: 

 

An infrared remote unit lets a user interact with our project while we are freely moving 

about. Remotes work like mice and trackballs, except they use infrared light to direct 

the cursor and require no cables to communicate. Remote mice work well for a lecture 

or other presentation in an auditorium or similar environment, when the speaker needs 

to move around the room. 
 
9) VOICE RECOGNITION SYSTEM: 

 

Voice recognition system facilitates hands free interaction with your project. These 

systems usually provide a unidirectional cardio, noise canceling microphone that 

automatically filters out background noise. 



 

Experiment: 2 
 

AIM: To study the Multimedia BASIC SOFTWARE TOOLS. 
 
REQUIREMENTS: Basic software tools. 
 
THEORY: 

 

1) Text editing and Word processing tools: - A word processor is usually the first 

software tool computer users learn. From letter invoice and story boards to project 

content word processors may also be our most often used tool, as we design or build 

a multimedia project. Word processor such as Microsoft Word and Word Perfect are 

powerful that includes spell checkers, table formatters, templates for letters, resume 

purchase orders and other common documents. In many word processors we can 

actually embed multimedia elements such as sound, images and video etc.  
 
 

 

2) OCR software network: - With optical character recognition (OCR) software, a 

flat-bed scanner and our computer, we can save many hours of rekeying printed 

words, and get the job done faster and more accurately than roomful of typists. OCR 

software turns bitmapped characters into electronically recognizable ASCII text. A 

scanner is typically used to create the bitmap. Then the software breaks the bitmap 

into chunks according to whether it contains text or graphics by examining the 

texture and density of area of the bitmap and by detecting edges. The text areas are 

then converted into ASCII character using probability and expert system algorithms.  
 
 

 

3) Painting and Drawing tools: - Painting and drawing tools as well as 3D 

modelers are perhaps the most important items in your toolkit because of all 

multimedia elements, the graphical impact of our project will likely have the 

greatest influence on the end user. Painting software such as Corel draw, free hand 

is dedicated to producing vector based line art easily printed to paper at high 

resolution.  



4) 3D modeling and animation tools: - With 3D modeling software, object 

rendered in perspective appear more realistic. We can create stunning scenes and 

wander through them by choosing just the right lighting and perspective for our 

final rendered image. Powerful modeling packages such as Infinite-D, auto desk, 

strata vision’s, secular logo motion, wave front, aids soft images. Important for 

multimedia developers, many 3D modeling applications also include export 

features enabling us to save a moving view or journey through our scenes as a 

quick time or AVI animation file. Each rends 3D image takes from a few seconds 

to few hours to complete, depending upon the complexity of the drawing and the 

number of drawn objects included in it. A good 3D modeling tool should include 

the following features: 
 
i. Ability to drag and drop primitive shapes into a scene.  
 
ii. Lathe and extrude features.  
 
iii. Color and texture mapping.  

 
iv. Ability to create and sculpt organic objects from scratch with Bezier spline 
drawing tools.  
 
v. Unlimited cameras with focal length.  

 

5) Image editing tools: - Image editing applications are specialized and powerful 

tools for enhancing and retouching existing bit-mapped images. These applications 

also provide many of the features and tools of painting and drawing programs and 

can be used to create images from scratch as well as images digitized from 

scanners, video frame grabbers, digital camera clip art files or original artwork files 

created with painting or drawing package.  

 

6) Animation: - Video and digital movie tools : today the most widely used tool 

for creating multimedia animations for Machintosh and Windows environment is 

Macromedia director. Animations and digitized video movies are sequences of bit-

mapped graphics scene, rapidly played back. Most authoring tools adopt either a 

frame or object oriented approach to animation, but rarely both. Moviemaking tools 

typically take advantage of quick time for Machintosh and Windows and Microsoft 

video for Windows technology and let you create, edit and present digitized motion 

video segments, usually a small window in your project. To make a movie from 

video, you need special hardware to convert the analog video signal into digital 

data movie making tool such as Primer, video shop, media studio pro and let you 

edit and assemble video clips captured from camera, tape and other digitized audio 

or midi files.  



7) Sound editing tools: - System sounds are shipped with both Machintosh and 

window system, and they are available as soon as we install the operating system. 

System sounds and beeps are used to indicate an error, warning or special user 

activity. Using sound editing software we can make our own sound effects. We 

need software for editing digital sounds. Although we can usually incorporate 

MIDI sound files in our multimedia project without learning any special skill, using 

editing tool to make our own MIDI file requires that we understand the way music 

is sequenced, stored and published. We need to know about tempos, clips, notations 

and instruments. And we will need a MIDI synthesizer or device connected to our 

computer. Many MIDI applications provide both sequencing and notation 

capabilities, and some let you edit both digital audio and MIDI within the same 

application. 



Experiment: 3 

 

Aim: - A PROGRAM TO VIEW A BMP FILE USING C OR C++ 
 

ALGORITHM: 
1. START   
2. DETECT THE GRAPHS AND ALSO INITIALIZE THE 
GRAPHICS.   
3. OPEN THE BMP FILE IF AVAILABLE AND SET ITS GRAPHICS.  
 
4. APPLY FOR SOME LOOPS FOR GETTING THE BMP FILE YOU 
WANT TO HAVE.   
5. COMPILE THE PROGRAM AND VIEW THE RESULT OF THE 
FILE.   
6. STOP.   
SOURCE CODE: 
#include<stdio.h>  
#include<conio.h> 
 
#include<graphics.h> 
void main() 
 
FILE 
*p; int i; 
 
int gd=DETECT,gm,x=0,y=480; 
int g; 
 
char c; 

initgraph(&gd,&gm," "); 

p=fopen("F4.bmp","r"); 

if(p==NULL) printf("file 

not found"); else 

for(i=0;i<=436;i++) 

fscanf(p,"%c",&c); 

 

while(fscanf(p,"%c",&c)!=EOF)  
{  
i=(int)c; 



x++;  
{  
if (x>=640)  
{  
x=0; y--;  
}  
putpixel(x,y,i);  
}  
}  
}  
getch();  
} 

 

EXPERIMENT: 4 
 
 
 

Aim: - A PROGRAM TO PRODUCE ANIMATION EFFEC TO 

TRIANGLE TRANSFORM INTO SQUARE AND THEN INTO 
 

CIRCLE:-ALGORITHM: 
 

1. START   
2. INITIALIZE THE GRAPHICS.   
3. SET THE COLOUR OF THE TRIANGLE.   
4. DRAW THE POLYNOMIAL FROM THE TRIANGLE.  
 
5. SET ITS COLOUR AND THEN TRANSFORM WHOLE INTO A CIRCLE 
AND FILL IN SOME COLOURS.   
6. STOP.   
SOURCE CODE:  
#include<stdio.h> 
#include<conio.h> 
#include<graphics.h> void 
main()  
{ 
 
int gd=DETECT,gm,poly[8],c; 
initgraph(&gd,&gm,""); 
poly[0]=250; poly[1]=200;  
poly[2]=200;  
poly[3]=300;  
poly[4]=300;  
poly[5]=300;  
poly[6]=250;  
poly[7]=200;  
setcolor(6); 



 
setfillstyle(SOLID_FILL,11); 
fillpoly(4,poly);  
getch();  
for(c=1;c<=50;c++)  
{ 
 
poly[0]--; poly[6]++; 
drawpoly(4,poly); 
delay(100);  
}  
getch();  
for(c=1;c<=25;c++)  
{ 
 
setcolor(6); 
circle(250,250,75-c); 
floodfill(1,1,10); 
delay(9);  
}  
getch();  
} 

 

Experiment No. 5 

Aim: - Write a program to insert drop down list. 
 
Source code: 
<html>  
<head> 
<script>  
function allowDrop(ev) 

{ ev.preventDefault();  
} 

 
function drag(ev) { 

ev.dataTransfer.setData("text", ev.target.id);  
} 

 
function drop(ev) { 

ev.preventDefault();  
var data = ev.dataTransfer.getData("text"); 
ev.target.appendChild(document.getElementById(data)); 

}  
</script> 
</head>  
<body> 
 
<div id="div1" ondrop="drop(event)" ondragover="allowDrop(event)"></div> 

 
<img id="drag1" src="img_logo.gif" draggable="true" 
ondragstart="drag(event)" width="336" height="69"> 



 
</body> 
</html> 

 

Experiment No:-6 

 

Aim: - Write a program to insert Table. 

 

Source Code:- 
<html>  
<body> 

 
<table style="width:100%"> 
<tr>  
<td>Jill</td> 

<td>Smith</td> 

<td>50</td> 

</tr> 

<tr> 

<td>Eve</td> 

<td>Jackson</td> 

<td>94</td> 

</tr> 

<tr> 

<td>John</td> 

<td>Doe</td> 

<td>80</td> 

</tr> 

</table> 

 
</body> 

</html> 

 

Experiment No.: -7 

 
Aim: - Write a program for Formatting Text. 

 

Source Code:- 
<html> 

<body> 

 
<p>This text is normal.</p> 

 
<p><i>This text is italic.</i></p> 

 
</body> 

</html> 



Experiment No: - 8 

 

Aim:-Write a program to multiple Images. 

 

Source Code:- 
<html>  
<head>  
<style> 
img { 

width:100%; 

} 

</style> 

</head>  
<body> 

 
<p>It is better to use the style attribute (instead of the width and height attributes), 
because it prevents  
internal or external styles sheets to change the original size of an image:</p> 

 
<img src="html5.gif" alt="HTML5 Icon" style="width:128px;height:128px;"> 
<img src="html5.gif" alt="HTML5 Icon" width="128" height="128"> 

 

</body> 

</html> 



Experiment No: - 9 

 

Aim: -How to work with Dreamweaver. 

 

Study:  
Step 1: Click on Start 
Step 2: Select Program 
 
Step 3: Select Macromedia Dreamweaver 
Step 4: Click on Dreamweaver  
You will get the screen as given below: 
 
On opening Dreamweaver you will get 3 main windows, (1) Object; which 
contains  
Character, Common, Forms, Frames, Head and Invisible. Many options are 
available  
under these, like under common you will get, insertion of image, rollover image, 
layer,  
tabular data, horizontal bar, line break, email link, date, flash movie, fireworks object, 

shockwave file, generator, plug-ins, active x controls, SSI etc; under character you will 

find some special character/symbols like ©, ®, £, ¥, ™ etc; under frames you will find 

 
different type/style of frames; under forms you will find all the elements of forms, 
like  
text box, password box, radio button, check box, selection box, jump menu, 
submit &  
reset button etc; (2) Properties; which provides the properties of the selected 
object/item,  
page properties etc; (3) Launcher; which contains: Site, Library, HTML Style, CSS 
Style, Behaviors, History, HTML Source; On clicking any of the item on the 
Launcher  
the subsequent window opens up. 
 
Before creating your web page you have to create a Root directory in which all of 
your  
work will be saved. Then in dream weaver create a Site and Provide the Root 
Directory (which you have created). To do this;  
Step 1: Select Site from Launcher window 
Step 2: Click on Define Site  
Step 3: Click on NEW  
Step 4: Give a name under “Site Name”  
Step 5: Select the folder by browsing under “Local root folder” Step  
6: Click on OK  
Step 7: Click on DONE  
Now start working on Dreamweaver.  
Write your text, format the text, insert picture through Object window or by 
INSERT ->  
IMAGE. The Insert Menu provides you all the features available under the 
Object 



window. The modify menu provides you to modify the selection properties, page 
properties, link, table, frames etc. The Text menu helps to do all the formatting for 
the text, like selecting font, font-size, color, alignment etc. TO  
SAVE YOUR FILE  
Step 1: Click on FILE 
Step 2: Click on SAVE  
Step 3: Choose the folder in which you want to save 
 
Step 4: Provide a name to the file (with .htm / .html extension) Step 
5: Click on SAVE  
DIFFERENT MENUS 
 
File Menu: Under it we have New, Save, Save as, Save as template, Import, Export, 
Preview in browser etc. options.  
Edit Menu: In this menu we Cut, Copy, Paste, Undo, Redo, Select all, Find, 
Replace,  
Preference etc. options which helps us in editing the document. View 
Menu: Rulers, Grids, Plugins etc. are available under it.  
Insert Menu: It contains almost all the things which are there in the Object tool bar. 
Modify Menu: Under this we have Page properties, selection properties, Make 
link, remove link, link target, table, layer, frameset, library, template, timeline, 
translate etc. 
 
This menu helps to modify the page by choosing the option as per requirement. Text 

Menu: It helps to format the text written in the page by providing details, such as 

indent, outdent, list (ol, ul, dl), alignment, font, style, size, size increase, size decrease, 

 
HTML style, CSS style, color etc. It also provides to check the spellings in the 
page. Site Menu: This menu contains site files, site map, new site, open site, define 
site options.  
Window Menu: It contains all the different windows, like, object, properties, 
launcher,  
site file, site map, CSS, timeline, history, behavior, layer, frame, library, 
template etc.  
ADDING A LAYER TO THE TIMELINE AND 
GIVING MOTION TO THE LAYER.  
Step 1: Choose Layer from Common toolbar and draw a layer. Step 
2: Write the text inside the Layer. 



Step 3: Click on Modify (when the layer is selected) 
Step 4: Click on Timeline  
Step 5: Click on Add layer to timeline. 
 
Step 6: Modify -> Timeline -> Select Record path to Layer Step 
7: Drag the layer as per your wish to define a path. Step 8: Tick 
on Auto Play & Loop (if required)  
Step 9: Open it in the Browser to se the effect. 
INSERTING SCRIPTS TO YOUR PAGE Step 1: 
Click on Insert  
Step 2: Click on Script  
Step 3: Choose the type of Script Step  
4: Write the code in “Content” Step 5:  
To finish click on OK  
INSERTING  EXTERNAL  MEDIA’S  IN  THE  
WEB PAGE  
Step 1: Click on the icon in the object tool bar Or 
 
Insert - > Media - > Choose the media type to be inserted 
Step 2: Find and select the file required (browse)  
Step 3: Click on OK 
 
ADDING SSI (SERVER-SIDE INCLUDE) TO 
THE PAGE  
Step 1: Click on the icon in the object tool bar Or 
Insert -> SSI  
Step 2: Select the file 
Step 3: Add the file  
Step 4: Provide the URL (where to be attached)  
Step 5: Provide information on Relative to the document or to the “Site Root” Step  
6: Click on OK 
 
TO SHOW/HIDE THE SSI DOCUMENT IN 
THE PAGE  
Step 1: Click on Edit Step 
2: Select reference Step 3: 
Select Translation Step 4: 
Click on SSI  
Step 5: For showing the SSI file; choose one from the following option:  
a) a) in all files   
b) b) in no files   
c) c) in files with extension (stm, htm, html, shtm, shtml)  
 
d) d) in files matching one of these expressions “<!-- #include” Example : <!-- 
#include virtual="/virtual campus/bitmain/result.html" --> Step 6: Click on OK  



ADDING CSS STYLE TO YOUR PAGE  
Step 1: Click on Window Menu  
Step 2: Select CSS Styles  
Or Click on CSS Styles in the “Launcher”  
Step 3: Click on New to create a new CSS style  
Step 4: Choose the Type  
a) a) Make custom style   
b) b) Redefine HTML  
 
c) c) Use CSS Selection 
Step 5: Give a name Step 
Click OK   
On choosing (a) of step 4 you will get a new screen in which you have to 
provide the   
following details in Category:   
i. i. Type : Provide the Font, Size, Style, Weight, Decoration, then click OK   
ii. ii. Background: provide a Color or insert an image, then click OK iii.   
iii. Block: Give the alignment style, then click OK   
iv. iv. Box: Provide the margin setup of Top, Left, Right & Bottom, then click 
OK   
v. v. Border: Provide the width & color, then click OK   
vi. vi. List: Select the list type (OL, UL, DL), then click OK   
vii. vii. Positioning: Provide the style, Visibility, Z-index, Placement (Top, Left, 
Right & Bottom), click OK   
After providing the details, select the style from the CSS style window. Choose where 
to   
apply this style (body, p, layer etc), by clicking on Apply button in the CSS style 
window.   
ADDING A XML FILE TO YOUR PAGE  
 
Step 1: Choose File -> Import XML into Template 
Step 2: Select the XML file & click Open   
When an XML file is imported, Dreamweaver merges the XML content into the 
template, which is being specified in the XML file and shows the result in the 
document   
window of Dreamweaver. If that specified template is not found then 
Dreamweaver   
prompts to select another template for use.   
The XML file should contain the name of the template and editable region as XML 
tags.   
EXAMPLE:  

<doctitle>   
<![CDATA[<title>newtemplate</title>]]>  



</doctitle> 
<Edit-Region> 
 
<![CDATA[{Edit-
Region}]]> </Edit-Region>  
Here doctitle identifies the title of the template and edit-region identifies the 
editable  
region. 
 
But in a standard Dreamweaver file XML tags use the “item name”. The above 
example  
(XML tags) is given below in standard Dreamweaver file: <item 
name="doctitle">  
<![CDATA[ <title>newtemplate</title>]]> 
</item>  
<item name="Edit-Region"> 
<![CDATA[{Edit-Region}]]></item> 
</item>  
Here “item name=doctitle” identifies the title of the template and “item 
name=edit  
region” identifies the editable region. 
 
TO EXPORT A DREAMWEAVER DOCUMENT AS 
XML FILE  
Step 1: Choose File -> Open,  
Step 2: Select the document that uses a template (and has editable regions) Step 3: 
Click Open  
Step 4: Choose File -> Export -> Export Editable Regions as XML. Step 
5: In the XML dialog box, choose a tag notation  
Step 6: Click OK. 
 
Step 7: Enter a name for the XML file 
Step 8: Click Save.  
When the document is exported, the generated XML file contains the name of 
the template the document is using and all editable region names. 



Experiment No.: -10 

 

Aim:- Write a program to of java script. 
 
Source code: 

 

<html> 

<body> 

 

<h1>My First JavaScript</h1> 

 
<p id="demo">JavaScript can change the style of an 
HTML element.</p> 
 

<script>  
function myFunction() { 

document.getElementById("demo").style.fontSize = "25px"; 
} 

</script> 

 

<button type="button" onclick="myFunction()">Click Me!</button> 
 

</body> 

</html> 
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